Did you know that you can navigate the posts by swiping left and right?

Install dotnet core on Debian sid (unstable)

14 Apr 2017 . Category . Comments #research #fsharp #braintrust

  • None of the existing installers worked at all
  • Modified the install script to handle Debian 9 and a bash shell
  • After it runs do find /opt/dotnet -name '*.so' -type f -print | xargs ldd | grep 'not found' to see if you are missing any libraries
  • For me, it was liblldb.so. I installed liblldb-3.7 and then linked the library to /usr/lib/x86_64-linux-gnu/liblldb.so
  • Even after this, dotnet restore would segfault, apparently because dotnet depends on old versions of libcurl3
  • Resolved by adding stable.list to sources.list.d, running apt-get update, and then running apt-get install libcurl3=7.38.0-4+deb8u5 libcurl4-openssl-dev=7.38.0-4+deb8u5